That1580/1510 mini mixer

Where we discuss new analog design ideas for Pro Audio and modern spins on vintage ones.
User avatar
mediatechnology
Posts: 2922
Joined: Sat Aug 11, 2007 2:34 pm
Location: Oak Cliff, Texas
Contact:

Re: That1580/1510 mini mixer

Post by mediatechnology » Wed Nov 15, 2017 6:51 am

All those poor qfn chips
...and the people who have to solder them. I remain amazed you got any to work.

Hats off to your SMT soldering skills.

Wish we had a thumbs up emoticon.
Mack is naming names.
Big names in H-Wood / Gov’t (local/federal).

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Wed Nov 15, 2017 10:45 am

I think you're way overestimating my skills. Actually I did a lot of them wrong, and then did the rework wrong.

If you follow sop you just get a stencil (which I did not do), put paste on and hot air them and they should be not so hard. I was using hot air btw and just doing touch ups around the edges with an iron. Next go round if I get a stencil I'm definitely getting a metal one. The one time I tried using those flexible stencils I didn't like it much and wound up not using enough paste.

The 1580 small size qfn is easier than the the larger 5171 since a small air nozzle can just about cover most of the surface area.

I'm also on the lookout for a really good brand of watery/loose paste and/or I'm going to purchase one of those cheap-ish electric dispensers. Not the production style footpump actuated ones, but the ones that look like electric toothbrushes. One of those kickstarter sites had one for sale a while ago.

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Fri Nov 17, 2017 1:18 pm

Got real close to finishing today, then problems.

5 channels were working well. I passed signal through all working channels and the preamps sounded really good.

I can't remember exactly the sequence of events following but I had phantom on (accidentally) the non-working channel with an sm-57 for testing. The mic diaphragm was making some static noises - not good. The mic works fine still, not even sure that having phantom was was the issue.

I reflowed the 1580 on that card twice to no avail.

Phantom blocking caps are working, I turned phantom on and measured dc at the bridge rectifier and it was negligible.

The 1580 on that card is very hot to the touch, almost burning, definitely hotter than others I checked.

Also one of the previously working channels presented problems afterward. It passes signal, accepts and reports gain changes but gain does not work. It's about 10db louder than the other channels at a constant level of gain, non-responsive.

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Sat Nov 18, 2017 4:46 am

The second channel that stopped working, which had previously passed signal at default gain, started acting the same as the other channel ie no signal was passing and then the microphone diaphragm started whining. I figured this had to be a short in the chip itself. Replaced the chip and it's working.

I'm concerned that something I'm doing during testing or rework is frying these chips. It could be the 1580 is more heat sensitive than the 5171. I really butchered a lot of the 5171's but they seemed indestructable.

It could be some sort of power surge when using the wall wart, turning phantom on (cable is good and mic is no getting damaged), or the rework/cleaning process ie drag soldering the chip edges is heating it up too much, or cleaning the chip with the iron is overheating it, or some other unknown short somewhere else.

On to replace the last non-working 1580 chip and see what happens.

User avatar
JR.
Posts: 2222
Joined: Sat May 24, 2008 7:21 pm

Re: That1580/1510 mini mixer

Post by JR. » Sat Nov 18, 2017 9:54 am

sometimes if there is a floating logic line you can get random results.... I recall working on a DSP last century that had a boot-up issue we finally traced to an open connection... sometimes it booted, sometimes not...

JR

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Sat Nov 18, 2017 10:59 am

Spi is very stable now. Afaik there are no floating logic lines. The only random logic-related thing that happens is sometimes when I hotplug the power jack to my board one channel doesn't reset correctly. A quick proper power cycle corrects it.

The current problem is one channel is stuck on a gain of something like 15db or so. It registers as if gain changes are updating but the gain never actually changes. At least it's passing signal which is an improvement. I wound up replacing that chip as well. Best guess is one of the Rg pins is not connected, but I already touched those up a bunch of times and they look like good joints. I'm thinking maybe I need to reflow or replace the 5171 on that channel as maybe the actual switching circuitry or resistors inside are damaged.

Then once that's all working I have to figure out if phantom power is somehow damaging the preamp chips.

User avatar
JR.
Posts: 2222
Joined: Sat May 24, 2008 7:21 pm

Re: That1580/1510 mini mixer

Post by JR. » Sat Nov 18, 2017 11:58 am

I think Wayne worked on a white paper about that... if caps charged to 48V get discharged quickly that can damage connected electronics with a negative voltage pulse.

JR

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Mon Nov 20, 2017 6:07 am

Replaced all the decoupling caps, still no luck.

Spi seems to be working properly, gain commands are ok. Audio is passing but gain never changes. Listening through phones it sounds a little distorted and noisy. Louder sounds cause the gain to overload recorder's vu. I was thinking maybe a problem with the servo or dc offset.

edit: yet another reflow did it. all channels now working, quiet, but have not tested phantom yet with mics. The phantom indicator is working, 48V is good on the power bus.

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Thu Nov 30, 2017 7:51 am

Too scared to permanently solder all the preamp cards into backplane. As of last test everything was working, but I haven''t tested all channels at once.

I tried to get some of my old 1510 preamp cards working and stuff them into a case, but I couldn't get proper signal passing. Cooked up an all in one board stereo preamp. I'll have it assembled at the fab house as a test to see how good a job they do. If it works out well mixer 2.0 will get assembled there.

https://1580mixer.shutterfly.com/pictures/61

two 1510's, 1 9v battery, ltc3265 but only using the negative regulator. +-5v rails, +9v goes to tps7a47 regulated to +5 - a little overkill but I have a few of them already.

weroflu
Posts: 39
Joined: Wed Apr 19, 2017 9:19 am

Re: That1580/1510 mini mixer

Post by weroflu » Thu Dec 07, 2017 1:11 pm

3d cad case for prototype. I'll soak it in conductive paint then paint some non conductive over that. Hopefully it will fit, but it's not that expensive to 3d print these buggers so one or two misses is ok. I might spring for a stainless steel 3d printed case even though they do co$t.

https://1580mixer.shutterfly.com/pictures/65

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 10 guests